IonCube Loader is a software instrument, that's needed to run files that are protected with ionCube PHP Encoder. The aforementioned is an application employed to make PHP code human unreadable, as a way to protect it from reverse engineering or illegal usage. Numerous script-driven apps, especially discussion forums, cms and electronic commerce solutions are encoded with ionCube PHP Encoder, which means that when you obtain a script and you find that ionCube is among the website hosting environment requirements, you need to make sure that your hosting server has the instrument pre-installed. Though it is not that hard to install it when you have your own server, it is close to impossible to do that on a shared web hosting server because the PHP environment should be precompiled and all of the clients on the server will be affected.

IonCube in Cloud Hosting

IonCube Loader is provided with all the cloud hosting packages that we supply, so any time you need it in order to install and run a script app which needs it, you can enable it with a click in the Advanced section of the Hepsia Control Panel. Since you can switch the PHP release that is active for your account in the same section, you need to enable the instrument for each new version which you set. If you're more experienced, you can use a php.ini file in a domain or subdomain folder and set both the PHP version as well as the status of ionCube Loader for this particular site only, without affecting the entire account. In this way you can run both new and older script apps for multiple sites inside the same account - a thing that you will not be able to do with numerous other hosting suppliers available on the market.

IonCube in Semi-dedicated Hosting

If you aquire a semi-dedicated server plan from us, you'll be able to employ any script-driven application that needs ionCube Loader because the software tool comes with all the servers which are a part of our cutting-edge cloud hosting platform. In addition, we support multiple versions of PHP, therefore if you switch from PHP 4 to 5.2 or 5.3, for example, you can enable ionCube for this particular version with only a click from your Hepsia Control Panel. Our system will remember your choice, and in case you move back to the previous release of PHP, the instrument will already be active. For more experienced users, we also offer the option to select the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the whole hosting account. This is done by putting a php.ini file inside a domain folder with a couple of lines of program code.